freightliner/thomas C2's

This topic contains 3 replies and was last updated by william-kelley 9 years 5 months ago
Author
william-kelley
November 29th, 2011 9:51pm
Post
Hey everyone,



I am having a problem with a couple of 08 C2's. With one the service/entrance door will only open once while the bus is running. turn the bus off and restart it and it will only open once again. when the bus is in accessory it will open and close all day long. There does not appear to be any cut or pinched wires from the module to the door. The bus runs fine and this is the only problem with this bus.



On the other bus the child minder does not cancel with button at the back of the bus. As soon as the key is turned off the horn starts to blow and will not stop till you disconnect the negative battery cable. The micro switches all seem to be adjusted properly. In the past changing the switch hub module would take care of the problem but not this time.

With both of these buses we are lacking in any kind of technical support and diagnostic equipment. Talking with the dealer has given me some ideas but they have not seen these problems themselves,at least the one I've talked too. If any one has any ideas I would sure like to hear them and will return the favor anytime I can.
jim-owen
November 30th, 2011 4:45am
Sounds like you have some interesting things happening. The most knowledgeable member, I think, to help you would be John Whelan aka schoolbusmechanic. He is a shop foreman for a county school bussing. Unfortunately, we have not heard from him recently. And apparently I am not smart enough to be able to find his e-mail or contact info anymore. MechanicHub just updated their website. I see that rmaizis is on-line. Maybe he will jump in.
blaise-bodway-2
October 11th, 2012 5:41pm
We have had the same issue and ours ended up being a corroded hot wire feeding the body control module. You will have 3 12v feeds and they may read 12v with a meter, but if you load the wire( we use a headlight bulb) the voltage will drop drasstically. We find most C2 issues to be related to that type of problem. The plastic housings they use on the wiring for protection seem to be the biggest culprit.
john-whelan-2
November 10th, 2012 12:58am
We've gone through all of our 2006 - 2007 C2 starting from the PDM on the driver's side front fender. First thing we do is remove the driver's side fender and start checking the harness. There has been an ongoing problem with the plastic loom rubbing through the harness which has been found to be strung too tight from the factory. It takes a couple of years for this problem to develop, we've gone through no starts, unable to release brakes and poor trans shifting or no shifting at all. One thing you can do is pull the module connectors and check for corrosion (they are not totally reliable providing an environmental seal). This condition will cause lots of haywire events like relays clicking on and off and switches self activating among other things (even with the power off). One other thing to try... while the fault is happening go along the harness and manhandle it up and down/back and forth....you may get lucky and find the problem.

Reply to: freightliner/thomas C2's